What’s Vulnerable › Vulnerabilities
CVE-2024-6847: SmartSearch WP <= 2.4.4 - Unauthenticated SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The Chatbot with ChatGPT WordPress plugin before 2.4.5 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users when submitting messages to the chatbot.
Affected products
- Chatbot with ChatGPT WordPress: before 2.4.5 — fixed in 2.4.5
How to fix
Upgrade to a fixed version: Chatbot with ChatGPT WordPress 2.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6847 or the next vulnerability affects your stack