What’s Vulnerable › Vulnerabilities
CVE-2024-6848: Post and Page Builder by BoldGrid – Visual Drag and Drop Editor <= 1.26.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via file uploads in all versions up to, and including, 1.26.6 due to insufficient input sanitization and output escaping affecting the boldgrid_canvas_image AJAX endpoint. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor: before 1.26.7 — fixed in 1.26.7
How to fix
Upgrade to a fixed version: boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor 1.26.7. Check the vendor advisory for mitigations.
References
- https://github.com/BoldGrid/post-and-page-builder/issues/612
- https://github.com/BoldGrid/post-and-page-builder/pull/613/commits/64c33a6d0c9dbb0151d3af5fee9e026df6c5a2f6
- https://plugins.trac.wordpress.org/browser/post-and-page-builder/tags/1.26.6/includes/class-boldgrid-editor-ajax.php#L372
- https://wordpress.org/plugins/post-and-page-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d5dcec8-fa36-43ab-9a35-0b391fe1d88e?source=cve
- https://github.com/BoldGrid/post-and-page-builder/issues/612
- https://github.com/BoldGrid/post-and-page-builder/pull/613/commits/64c33a6d0c9dbb0151d3af5fee9e026df6c5a2f6
- https://plugins.trac.wordpress.org/browser/post-and-page-builder/tags/1.26.6/includes/class-boldgrid-editor-ajax.php#L372
- https://wordpress.org/plugins/post-and-page-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d5dcec8-fa36-43ab-9a35-0b391fe1d88e?source=cve
Get alerted when CVE-2024-6848 or the next vulnerability affects your stack