What’s Vulnerable › Vulnerabilities
CVE-2024-6850: Carousel Slider < 2.2.14 - Editor+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Carousel Slider WordPress plugin before 2.2.4 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Carousel Slider: before 2.2.14 — fixed in 2.2.14
How to fix
Upgrade to a fixed version: Carousel Slider 2.2.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6850 or the next vulnerability affects your stack