What’s Vulnerable › Vulnerabilities
CVE-2024-6864: WP Last Modified Info <= 1.9.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via lmt-post-modified-info Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Last Modified Info plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘template’ attribute of the lmt-post-modified-info shortcode in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- infosatech WP Last Modified Info: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: infosatech WP Last Modified Info 1.9.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-last-modified-info/trunk/inc/Core/Frontend/PostView.php#L205
- https://plugins.trac.wordpress.org/changeset/3137253/
- https://plugins.trac.wordpress.org/changeset/3137253/#file23
- https://wordpress.org/plugins/wp-last-modified-info/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/87368d85-04d4-42e6-9ba6-2a1fc3b945a8?source=cve
Get alerted when CVE-2024-6864 or the next vulnerability affects your stack