What’s Vulnerable › Vulnerabilities
CVE-2024-6879: Quiz and Survey Master (QSM) < 9.1.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.1.1 fails to validate and escape certain Quiz fields before displaying them on a page or post where the Quiz is embedded, which could allows contributor and above roles to perform Stored Cross-Site Scripting (XSS) attacks.
Affected products
- ExpressTech Quiz And Survey Master: before 9.1.1 — fixed in 9.1.1
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6879 or the next vulnerability affects your stack