What’s Vulnerable › Vulnerabilities
CVE-2024-6884: Gutenberg Blocks with AI by Kadence WP < 3.2.39 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenberg Blocks with AI by Kadence WP WordPress plugin before 3.2.39 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: before 3.2.39 — fixed in 3.2.39
How to fix
Upgrade to a fixed version: stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor 3.2.39. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6884 or the next vulnerability affects your stack