What’s Vulnerable › Vulnerabilities
CVE-2024-6889: Secure Copy Content Protection and Content Locking < 4.1.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Secure Copy Content Protection and Content Locking WordPress plugin before 4.1.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- ays-pro Secure Copy Content Protection and Content Locking: before 4.1.7 — fixed in 4.1.7
How to fix
Upgrade to a fixed version: ays-pro Secure Copy Content Protection and Content Locking 4.1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6889 or the next vulnerability affects your stack