What’s Vulnerable › Vulnerabilities
CVE-2024-6910: EventON < 2.2.17 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The EventON WordPress plugin before 2.2.17 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Affected products
- EventON: before 2.2.17 — fixed in 2.2.17
How to fix
Upgrade to a fixed version: EventON 2.2.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6910 or the next vulnerability affects your stack