What’s Vulnerable › Vulnerabilities
CVE-2024-6930: WP Booking Calendar <= 10.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via bookingform Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Booking Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'type' attribute within the plugin's bookingform shortcode in all versions up to, and including, 10.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPdevelop/Oplugins Booking Calendar (WordPress plugin): before 10.2.2 — fixed in 10.2.2
How to fix
Upgrade to a fixed version: WPdevelop/Oplugins Booking Calendar (WordPress plugin) 10.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/booking/trunk/core/lib/wpdev-booking-class.php#L849
- https://plugins.trac.wordpress.org/changeset/3123628/
- https://wordpress.org/plugins/booking/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2aaca776-03ce-43bb-9553-f455f57124a3?source=cve
- https://plugins.trac.wordpress.org/browser/booking/trunk/core/lib/wpdev-booking-class.php#L849
- https://plugins.trac.wordpress.org/changeset/3123628/
- https://wordpress.org/plugins/booking/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2aaca776-03ce-43bb-9553-f455f57124a3?source=cve
Get alerted when CVE-2024-6930 or the next vulnerability affects your stack