What’s Vulnerable › Vulnerabilities
CVE-2024-6972
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-25 · updated 2026-06-17
- Weakness: CWE-319
Description
In affected versions of Octopus Server under certain circumstances it is possible for sensitive variables to be printed in the task log in clear-text.
Affected products
- Octopus Deploy Octopus Server: from 2024.1.437 before 2024.1.12759; from 2024.2.101 before 2024.2.9193 — fixed in 2024.1.12759, 2024.2.9193
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.1.12759, 2024.2.9193. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2024/sa2024-06/
- https://advisories.octopus.com/post/2024/sa2024-06/
Get alerted when CVE-2024-6972 or the next vulnerability affects your stack