What’s Vulnerable › Vulnerabilities
CVE-2024-6984
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-209
Description
An issue was discovered in Juju that resulted in the leak of the sensitive context ID, which allows a local unprivileged attacker to access other sensitive data or relation accessible to the local charm.
Affected products
- Canonical Juju: from 2.9 before 2.9.50; from 3.1 before 3.1.9; from 3.3 before 3.3.6; from 3.4 before 3.4.5; from 3.5 before 3.5.3 — fixed in 2.9.50, 3.1.9, 3.3.6, 3.4.5, 3.5.3
How to fix
Upgrade to a fixed version: Canonical Juju 2.9.50, 3.1.9, 3.3.6, 3.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/juju/juju/commit/da929676853092a29ddf8d589468cf85ba3efaf2
- https://github.com/juju/juju/security/advisories/GHSA-6vjm-54vp-mxhx
- https://www.cve.org/CVERecord?id=CVE-2024-6984
- https://github.com/juju/juju/commit/da929676853092a29ddf8d589468cf85ba3efaf2
- https://github.com/juju/juju/security/advisories/GHSA-6vjm-54vp-mxhx
- https://www.cve.org/CVERecord?id=CVE-2024-6984
Get alerted when CVE-2024-6984 or the next vulnerability affects your stack