What’s Vulnerable › Vulnerabilities
CVE-2024-6987: Orchid Store <= 1.5.6 - Missing Authorization to Authenticated (Subscriber+) Limited Plugin Activation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The Orchid Store theme for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'orchid_store_activate_plugin' function in all versions up to, and including, 1.5.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate the Addonify Floating Cart For WooCommerce plugin if it is installed.
Affected products
- themebeez Orchid Store: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: themebeez Orchid Store 1.5.7. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/browser/orchid-store/1.5.6/functions.php#L300
- https://themes.trac.wordpress.org/changeset/237704/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5402f206-0375-4c47-8a5c-e8ea5742493d?source=cve
Get alerted when CVE-2024-6987 or the next vulnerability affects your stack