What’s Vulnerable › Vulnerabilities
CVE-2024-7031: File Manager Pro – Filester <= 1.8.2 - Authenticated Plugin Settings Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-03 · updated 2026-06-17
- Weakness: CWE-862
Description
The File Manager Pro – Filester plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'njt_fs_saveSettingRestrictions' function in all versions up to, and including, 1.8.2. This makes it possible for authenticated attackers, with a role that has been granted permissions by an Administrator, to update the plugin settings for user role restrictions, including allowing file types such as .php to be uploaded.
Affected products
- ninjateam File Manager Pro – Filester: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: ninjateam File Manager Pro – Filester 1.8.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/filester/trunk/includes/File_manager/FileManager.php#L566
- https://plugins.trac.wordpress.org/changeset/3129722/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/aef584bd-60a5-4bf2-b8d3-58e3b45e785e?source=cve
- https://nowotarski.info/wordpress-nonce-authorization/
Get alerted when CVE-2024-7031 or the next vulnerability affects your stack