What’s Vulnerable › Vulnerabilities
CVE-2024-7042: Prompt Injection in langchain-ai/langchainjs Leading to SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.
Affected products
- langchain-ai/langchain: before 0.3.1 — fixed in 0.3.1
How to fix
Upgrade to a fixed version: langchain-ai/langchain 0.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchainjs/commit/615b9d9ab30a2d23a2f95fb8d7acfdf4b41ad7a6
- https://huntr.com/bounties/b612defb-1104-4fff-9fef-001ab07c7b2d
Get alerted when CVE-2024-7042 or the next vulnerability affects your stack