What’s Vulnerable › Vulnerabilities

CVE-2024-7047: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

A cross site scripting vulnerability exists in GitLab CE/EE affecting all versions from 16.6 prior to 17.0.5, 17.1 prior to 17.1.3, 17.2 prior to 17.2.1 allowing an attacker to execute arbitrary scripts under the context of the current logged in user.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.0.5, 17.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7047 or the next vulnerability affects your stack