What’s Vulnerable › Vulnerabilities

CVE-2024-7055: FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

Description

A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

Affected products

How to fix

Upgrade to a fixed version: FFmpeg 4.3.8, 4.4.5, 5.1.6, 6.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7055 or the next vulnerability affects your stack