What’s Vulnerable › Vulnerabilities
CVE-2024-7056: WPForms < 1.9.1.6 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPForms WordPress plugin before 1.9.1.6 does not sanitise and escape some of its settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- smub WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More: before 1.9.1.6 — fixed in 1.9.1.6
How to fix
Upgrade to a fixed version: smub WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More 1.9.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7056 or the next vulnerability affects your stack