What’s Vulnerable › Vulnerabilities
CVE-2024-7057: Improper Access Control in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-25 · updated 2026-06-17
- Weakness: CWE-284
Description
An information disclosure vulnerability in GitLab CE/EE affecting all versions starting from 16.7 prior to 17.0.5, starting from 17.1 prior to 17.1.3, and starting from 17.2 prior to 17.2.1 where job artifacts can be inappropriately exposed to users lacking the proper authorization level.
Affected products
- GitLab: from 16.7 before 17.0.5; from 17.1 before 17.1.3; from 17.2 before 17.2.1 — fixed in 17.0.5, 17.1.3, 17.2.1
How to fix
Upgrade to a fixed version: GitLab 17.0.5, 17.1.3, 17.2.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/458501
- https://hackerone.com/reports/2475135
- https://gitlab.com/gitlab-org/gitlab/-/issues/458501
- https://hackerone.com/reports/2475135
Get alerted when CVE-2024-7057 or the next vulnerability affects your stack