What’s Vulnerable › Vulnerabilities
CVE-2024-7059
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-470
Description
A high-severity vulnerability that can lead to arbitrary code execution on the system hosting the Web SDK role was found in the Genetec Security Center product line.
Affected products
- Genetec Inc. Genetec Security Center: before 5.8.2.1; from 5.9.0.0 before 5.9.5.8; from 5.10.0.0 before 5.10.4.23; from 5.11.0.0 before 5.11.3.13; from 5.12.0.0 before 5.12.1.3; from 5.12.2.0 before 5.12.2.1 — fixed in 5.10.4.23, 5.11.3.13, 5.12.1.3, 5.12.2.1, 5.8.2.1, 5.9.5.8
How to fix
Upgrade to a fixed version: Genetec Inc. Genetec Security Center 5.10.4.23, 5.11.3.13, 5.12.1.3, 5.12.2.1. Check the vendor advisory for mitigations.
References
- https://resources.genetec.com/security-advisories/high-severity-vulnerability-affecting-security-center-web-sdk-role
- https://ressources.genetec.com/bulletins-de-securite/vulnerabilite-de-haute-severite-affectant-le-role-sdk-web-de-security-center
Get alerted when CVE-2024-7059 or the next vulnerability affects your stack