What’s Vulnerable › Vulnerabilities
CVE-2024-7062: Local Privilege Escalation in Nimble Commander <= v1.6.0, Build 4087
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-26 · updated 2026-06-17
- Weakness: CWE-863
Description
Nimble Commander suffers from a privilege escalation vulnerability due to the server (info.filesmanager.Files.PrivilegedIOHelperV2) performing improper/insufficient validation of a client’s authorization before executing an operation. Consequently, it is possible to execute system-level commands as the root user, such as changing permissions and ownership, obtaining a handle (file descriptor) of an arbitrary file, and terminating processes, among other operations.
Affected products
- Nimble Commander: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: Nimble Commander 1.6.1. Check the vendor advisory for mitigations.
References
- https://pentraze.com/vulnerability-reports/CVE-2024-7062/
- https://pentraze.com/vulnerability-reports/CVE-2024-7062/
Get alerted when CVE-2024-7062 or the next vulnerability affects your stack