What’s Vulnerable › Vulnerabilities
CVE-2024-7063: ElementsKit Pro <= 3.6.6 - Authenticated (Contributor+) Sensitive Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-15 · updated 2026-06-17
- Weakness: CWE-200
Description
The ElementsKit Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.6.6 via the 'render_raw' function. This can allow authenticated attackers, with Contributor-level permissions and above, to extract sensitive data including private, future, and draft posts.
Affected products
- wpmet ElementsKit Pro: before 3.6.7 — fixed in 3.6.7
How to fix
Upgrade to a fixed version: wpmet ElementsKit Pro 3.6.7. Check the vendor advisory for mitigations.
References
- https://wpmet.com/plugin/elementskit/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d35dd18b-0f05-482f-aef3-08977cbec8a0?source=cve
Get alerted when CVE-2024-7063 or the next vulnerability affects your stack