What’s Vulnerable › Vulnerabilities
CVE-2024-7084: Ajax Search Lite < 4.12.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ajax Search Lite WordPress plugin before 4.12.1 does not sanitise and escape some parameters, which could allow users with a role as low as Admin+ to perform Cross-Site Scripting attacks.
Affected products
- Ajax Search Lite: before 4.12.1 — fixed in 4.12.1
How to fix
Upgrade to a fixed version: Ajax Search Lite 4.12.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7084 or the next vulnerability affects your stack