What’s Vulnerable › Vulnerabilities
CVE-2024-7102: Execution with Unnecessary Privileges in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-13 · updated 2026-06-17
- Weakness: CWE-250
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.4 prior to 17.5.0 which allows an attacker to trigger a pipeline as another user under certain circumstances.
Affected products
- GitLab: from 16.4.0 before 17.5.0 — fixed in 17.5.0
How to fix
Upgrade to a fixed version: GitLab 17.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7102 or the next vulnerability affects your stack