What’s Vulnerable › Vulnerabilities

CVE-2024-7110: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

Description

An issue was discovered in GitLab EE affecting all versions starting 17.0 to 17.1.6, 17.2 prior to 17.2.4, and 17.3 prior to 17.3.1 allows an attacker to execute arbitrary command in a victim's pipeline through prompt injection.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.6, 17.2.4, 17.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7110 or the next vulnerability affects your stack