What’s Vulnerable › Vulnerabilities
CVE-2024-7129: Appointment Booking Calendar < 1.6.7.43 - Admin+ Template Injection to RCE
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
Description
The Appointment Booking Calendar WordPress plugin before 1.6.7.43 does not escape template syntax provided via user input, leading to Twig Template Injection which further exploited can result to remote code Execution by high privilege such as admins
Affected products
- Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin: before 1.6.7.43 — fixed in 1.6.7.43
How to fix
Upgrade to a fixed version: Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin 1.6.7.43. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7129 or the next vulnerability affects your stack