What’s Vulnerable › Vulnerabilities
CVE-2024-7132: CoBlocks < 3.1.13 - Editor+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder Gutenberg Blocks WordPress plugin before 3.1.13 does not escape the content of post embed via one of its block, which could allow users with the capability to publish posts (editor and admin by default) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- godaddy Page Builder Gutenberg Blocks – CoBlocks: before 3.1.13 — fixed in 3.1.13
How to fix
Upgrade to a fixed version: godaddy Page Builder Gutenberg Blocks – CoBlocks 3.1.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7132 or the next vulnerability affects your stack