What’s Vulnerable › Vulnerabilities
CVE-2024-7133: My Sticky Bar < 2.7.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any WordPress plugin before 2.7.3 does not validate and escape some of its settings before outputting them back in the page, which could allow users with a high role to perform Stored Cross-Site Scripting attacks.
Affected products
- Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme 2.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7133 or the next vulnerability affects your stack