What’s Vulnerable › Vulnerabilities
CVE-2024-7258: WooCommerce Google Feed Manager <= 2.8.0 - Missing Authorization to Authenticated (Contributor+) Arbitrary File Deletion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The WooCommerce Google Feed Manager plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'wppfm_removeFeedFile' function in all versions up to, and including, 2.8.0. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Affected products
- aukejomm WPMR Google Feed Manager for WooCommerce – Sell on Google Merchant Center & Shopping: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: aukejomm WPMR Google Feed Manager for WooCommerce – Sell on Google Merchant Center & Shopping 2.9.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-product-feed-manager/trunk/includes/data/js/wppfm_ajaxdatahandling.js#L537
- https://plugins.trac.wordpress.org/browser/wp-product-feed-manager/trunk/includes/data/js/wppfm_ajaxdatahandling.js#L546
- https://plugins.trac.wordpress.org/browser/wp-product-feed-manager/trunk/includes/data/js/wppfm_ajaxdatahandling.js#L575
- https://plugins.trac.wordpress.org/changeset/3137475/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ffd6e18d-9173-4911-af64-5d54c6d2e052?source=cve
Get alerted when CVE-2024-7258 or the next vulnerability affects your stack