What’s Vulnerable › Vulnerabilities
CVE-2024-7259: Ovirt-engine: potential exposure of cleartext provider passwords via web ui
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-312
Description
A flaw was found in oVirt. A user with administrator privileges, including users with the ReadOnlyAdmin permission, may be able to use browser developer tools to view Provider passwords in cleartext.
Affected products
- ovirt-engine: before 4.5.7 — fixed in 4.5.7
How to fix
Upgrade to a fixed version: ovirt-engine 4.5.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2024-7259
- https://bugzilla.redhat.com/show_bug.cgi?id=2314229
Get alerted when CVE-2024-7259 or the next vulnerability affects your stack