What’s Vulnerable › Vulnerabilities
CVE-2024-7272: FFmpeg swresample.c fill_audiodata heap-based overflow
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-122
Description
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- FFmpeg: before 5.1.6 — fixed in 5.1.6
How to fix
Upgrade to a fixed version: FFmpeg 5.1.6. Check the vendor advisory for mitigations.
References
- https://ffmpeg.org/
- https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc5
- https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc6
- https://vuldb.com/?ctiid.273945
- https://vuldb.com/?id.273945
Get alerted when CVE-2024-7272 or the next vulnerability affects your stack