What’s Vulnerable › Vulnerabilities
CVE-2024-7296: Incorrect Authorization in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab EE affecting all versions from 16.5 prior to 17.7.7, 17.8 prior to 17.8.5, and 17.9 prior to 17.9.2 which allowed a user with a custom permission to approve pending membership requests beyond the maximum number of allowed users.
Affected products
- GitLab: from 16.5.0 before 17.7.7; from 17.8.0 before 17.8.5; from 17.9.0 before 17.9.2 — fixed in 17.7.7, 17.8.5, 17.9.2
How to fix
Upgrade to a fixed version: GitLab 17.7.7, 17.8.5, 17.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7296 or the next vulnerability affects your stack