What’s Vulnerable › Vulnerabilities
CVE-2024-7297: Langflow Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-913
Description
Langflow versions prior to 1.0.13 suffer from a Privilege Escalation vulnerability, allowing a remote and low privileged attacker to gain super admin privileges by performing a mass assignment request on the '/api/v1/users' endpoint.
Affected products
- IBM Langflow OSS: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.0.13. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2024-26
- https://www.tenable.com/security/research/tra-2024-26
Get alerted when CVE-2024-7297 or the next vulnerability affects your stack