What’s Vulnerable › Vulnerabilities
CVE-2024-7302: Blog2Social: Social Media Auto Post & Scheduler <= 7.5.4 - Authenticated (Author+) Stored Cross-Site Scripting via File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blog2Social: Social Media Auto Post & Scheduler plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 3gp2 file uploads in all versions up to, and including, 7.5.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the 3gp2 file.
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 7.5.5 — fixed in 7.5.5
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 7.5.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/blog2social/tags/7.5.4/includes/Ajax/Post.php#L78
- https://plugins.trac.wordpress.org/changeset/3128861/
- https://plugins.trac.wordpress.org/changeset/3128861/#file434
- https://wordpress.org/plugins/blog2social/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/94afe3e2-a1f1-470b-afaf-c7926beaec9a?source=cve
Get alerted when CVE-2024-7302 or the next vulnerability affects your stack