What’s Vulnerable › Vulnerabilities
CVE-2024-7304: Ninja Tables – Easiest Data Table Builder <= 5.0.12 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Tables – Easiest Data Table Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 5.0.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- WPManageNinja LLC Ninja Tables: before 5.0.13 — fixed in 5.0.13
How to fix
Upgrade to a fixed version: WPManageNinja LLC Ninja Tables 5.0.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ninja-tables/tags/5.0.12/app/Hooks/filters.php#L28
- https://plugins.trac.wordpress.org/changeset/3140370/
- https://plugins.trac.wordpress.org/changeset/3140370/#file408
- https://wordpress.org/plugins/ninja-tables/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b1eb6896-2de3-4d4d-9b5f-253aaffd193b?source=cve
Get alerted when CVE-2024-7304 or the next vulnerability affects your stack