What’s Vulnerable › Vulnerabilities
CVE-2024-7313: Shield Security < 20.0.6 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Shield Security WordPress plugin before 20.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- paultgoodchild Shield: Blocks Bots, Protects Users, and Prevents Security Breaches: before 20.0.6 — fixed in 20.0.6
How to fix
Upgrade to a fixed version: paultgoodchild Shield: Blocks Bots, Protects Users, and Prevents Security Breaches 20.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7313 or the next vulnerability affects your stack