What’s Vulnerable › Vulnerabilities
CVE-2024-7315: Migration, Backup, Staging – WPvivid < 0.9.106 - Unauthenticated Sensitive Data Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-338
Description
The Migration, Backup, Staging WordPress plugin before 0.9.106 does not use sufficient randomness in the filename that is created when generating a backup, which could be bruteforced by attackers to leak sensitive information about said backups.
Affected products
- wpvividplugins WPvivid — Backup, Migration & Staging: before 0.9.106 — fixed in 0.9.106
How to fix
Upgrade to a fixed version: wpvividplugins WPvivid — Backup, Migration & Staging 0.9.106. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7315 or the next vulnerability affects your stack