What’s Vulnerable › Vulnerabilities
CVE-2024-7356: Zephyr Project Manager <= 3.3.100 - Authenticated (Subscriber+) Stored Cross-Site Scripting via filename Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Zephyr Project Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘filename’ parameter in all versions up to, and including, 3.3.100 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Dylan James Zephyr Project Manager: before 3.3.101 — fixed in 3.3.101
How to fix
Upgrade to a fixed version: Dylan James Zephyr Project Manager 3.3.101. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/zephyr-project-manager/trunk/assets/js/core-admin.js#L2975
- https://plugins.trac.wordpress.org/changeset/3129917/
- https://wordpress.org/plugins/zephyr-project-manager/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d7fa63b7-2e7f-4ed5-96b9-ae06d429af47?source=cve
Get alerted when CVE-2024-7356 or the next vulnerability affects your stack