What’s Vulnerable › Vulnerabilities

CVE-2024-7404: Improper Restriction of Rendered UI Layers or Frames in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 17.2 prior to 17.3.7, starting from 17.4 prior to 17.4.4 and starting from 17.5 prior to 17.5.2, which could have allowed an attacker gaining full API access as the victim via the Device OAuth flow.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.3.7, 17.4.4, 17.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7404 or the next vulnerability affects your stack