What’s Vulnerable › Vulnerabilities
CVE-2024-7419: WP All Export Pro <= 1.9.1 - Unauthenticated Remote Code Execution via Custom Export Fields
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-94
Description
The WP ALL Export Pro plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.9.1 via the custom export fields. This is due to the missing input validation and sanitization of user-supplied data. This makes it possible for unauthenticated attackers to inject arbitrary PHP code into form fields that get executed on the server during the export, potentially leading to a complete site compromise. As a prerequisite, the custom export field should include fields containing user-supplied data.
Affected products
- WP All Export Pro: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: WP All Export Pro 1.9.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/40b57370-4fd7-4316-9e99-a3f1d34616e8?source=cve
- https://www.wpallimport.com/upgrade-to-wp-all-export-pro/
Get alerted when CVE-2024-7419 or the next vulnerability affects your stack