What’s Vulnerable › Vulnerabilities
CVE-2024-7425: WP All Export Pro <= 1.9.1 - Authenticated (ShopManager+) Arbtirary Options Update
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-94
Description
The WP ALL Export Pro plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to improper user input validation and sanitization in all versions up to, and including, 1.9.1. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
Affected products
- WP All Export Pro: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: WP All Export Pro 1.9.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c9205896-487d-4b8f-84cf-7ba16e1205e3?source=cve
- https://www.wpallimport.com/upgrade-to-wp-all-export-pro/
Get alerted when CVE-2024-7425 or the next vulnerability affects your stack