What’s Vulnerable › Vulnerabilities
CVE-2024-7429: Zotpress <= 7.3.12 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-284
Description
The Zotpress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the Zotpress_process_accounts_AJAX function in all versions up to, and including, 7.3.12. This makes it possible for authenticated attackers, with Contributor-level access and above, to reset the plugin's settings.
Affected products
- Katie Zotpress: before 7.3.13 — fixed in 7.3.13
How to fix
Upgrade to a fixed version: Katie Zotpress 7.3.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/zotpress/trunk/lib/admin/admin.php#L40
- https://plugins.trac.wordpress.org/changeset/3153348/zotpress/trunk/lib/admin/admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f38676b-270f-4b0f-bc98-a14a26b86a50?source=cve
Get alerted when CVE-2024-7429 or the next vulnerability affects your stack