What’s Vulnerable › Vulnerabilities
CVE-2024-7435: Attire <= 2.0.6 - Authenticated (Contributor+) PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-31 · updated 2026-06-17
- Weakness: CWE-502
Description
The Attire theme for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.0.6 via deserialization of untrusted input. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- shafayat-alam Attire: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: shafayat-alam Attire 2.0.7. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=240321%40attire%2F2.0.7&old=231937%40attire%2F2.0.6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f21cbe18-77e1-4a9a-96a0-74edaef0db3e?source=cve
Get alerted when CVE-2024-7435 or the next vulnerability affects your stack