What’s Vulnerable › Vulnerabilities
CVE-2024-7475: Improper Access Control in lunary-ai/lunary
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-862
Description
An improper access control vulnerability in lunary-ai/lunary version 1.3.2 allows an attacker to update the SAML configuration without authorization. This vulnerability can lead to manipulation of authentication processes, fraudulent login requests, and theft of user information. Appropriate access controls should be implemented to ensure that the SAML configuration can only be updated by authorized users.
Affected products
- lunary-ai/lunary: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/8f563c77d8614a72980113f530c7a9ec15a5f8d5
- https://huntr.com/bounties/78c824f7-3b6d-443d-bb76-0f8031c6c126
Get alerted when CVE-2024-7475 or the next vulnerability affects your stack