What’s Vulnerable › Vulnerabilities

CVE-2024-7476: Broken Access Control in lunary-ai/lunary

Description

A broken access control vulnerability exists in lunary-ai/lunary versions 1.2.7 through 1.4.2. The vulnerability allows an authenticated attacker to modify any user's templates by sending a crafted HTTP POST request to the /v1/templates/{id}/versions endpoint. This issue is resolved in version 1.4.3.

Affected products

How to fix

Upgrade to a fixed version: lunary-ai/lunary 1.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7476 or the next vulnerability affects your stack