What’s Vulnerable › Vulnerabilities
CVE-2024-7478: Username Enumeration via External User Stores in Multiple WSO2 Products Allows User Account Discovery
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-204
Description
When a WSO2 product is configured to use an external user store, the system fails to adequately obscure the existence or validity of usernames during authentication attempts. This oversight allows an attacker to repeatedly query the authentication mechanism with different username guesses, enabling the enumeration of valid usernames present in the external user store. The discovery of valid usernames can increase the risk of targeted brute-force attacks, social engineering, and information leakage. Attackers can leverage this information to craft more convincing phishing campaigns or other social engineering tactics to trick users into revealing sensitive data. The presence of username enumeration could also negatively impact an organization's reputation, leading to loss of customer trust, regulatory non-compliance, and potential legal and financial repercussions.
Affected products
- WSO2 API Manager: from 3.1.0 before 3.1.0.310; from 3.2.0 before 3.2.0.401; from 3.2.1 before 3.2.1.26; from 4.0.0 before 4.0.0.318; from 4.1.0 before 4.1.0.180; from 4.2.0 before 4.2.0.119 — fixed in 3.1.0.310, 3.2.0.401, 3.2.1.26, 4.0.0.318, 4.1.0.180, 4.2.0.119
- WSO2 Identity Server: from 5.10.0 before 5.10.0.326; from 6.0.0 before 6.0.0.214; from 6.1.0 before 6.1.0.198; from 7.0.0 before 7.0.0.67 — fixed in 5.10.0.326, 6.0.0.214, 6.1.0.198, 7.0.0.67
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.320 — fixed in 5.10.0.320
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.351 — fixed in 2.0.0.351
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.371 — fixed in 2.0.0.371
- WSO2 Carborn Identity Handler: from 1.4.0 before 1.4.0.15; from 1.4.0 before 1.4.0.16; from 1.4.11 before 1.4.11.14; from 1.4.37 before 1.4.37.1; from 1.6.1 before 1.6.1.5; from 1.7.1 before 1.7.1.1 — fixed in 1.4.0.15, 1.4.0.16, 1.4.11.14, 1.4.37.1, 1.6.1.5, 1.7.1.1
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.1.0.310, 3.2.0.401, 3.2.1.26, 4.0.0.318; WSO2 Identity Server 5.10.0.326, 6.0.0.214, 6.1.0.198, 7.0.0.67; WSO2 Identity Server As Key Manager 5.10.0.320; WSO2 Open Banking Am 2.0.0.351; WSO2 Open Banking Iam 2.0.0.371; WSO2 Carborn Identity Handler 1.4.0.15, 1.4.0.16, 1.4.11.14, 1.4.37.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7478 or the next vulnerability affects your stack