What’s Vulnerable › Vulnerabilities
CVE-2024-7486: MultiPurpose <= 1.2.0 - Authenticated (Contributor+) PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-502
Description
The MultiPurpose theme for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.2.0 via deserialization of untrusted input through the 'wpeden_post_meta' post meta. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- buywptemplates Multipurpose: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: buywptemplates Multipurpose 1.2.0. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/browser/multipurpose/1.2.0/functions.php#L134
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e029bc15-8128-42d1-8874-b0689312cb35?source=cve
Get alerted when CVE-2024-7486 or the next vulnerability affects your stack