What’s Vulnerable › Vulnerabilities
CVE-2024-7492: MainWP Child Reports <= 2.2 - Cross-Site Request Forgery to Arbitrary Options Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The MainWP Child Reports plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2. This is due to missing or incorrect nonce validation on the network_options_action() function. This makes it possible for unauthenticated attackers to update arbitrary options that can be leveraged for privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This is only exploitable on multisite instances.
Affected products
- MainWP Child: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: MainWP Child 2.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/mainwp-child-reports/trunk/classes/class-network.php#L346
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3131718%40mainwp-child-reports&new=3131718%40mainwp-child-reports&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cdd7971c-6f1c-437a-832c-e2b2817a197e?source=cve
Get alerted when CVE-2024-7492 or the next vulnerability affects your stack