What’s Vulnerable › Vulnerabilities
CVE-2024-7503: WooCommerce - Social Login <= 2.7.5 - Authentication Bypass to Account Takeover
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-288
Description
The WooCommerce - Social Login plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.5. This is due to the use of loose comparison of the activation code in the 'woo_slg_confirm_email_user' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the userID. This requires the email module to be enabled.
Affected products
- WPWeb WooCommerce - Social Login: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: WPWeb WooCommerce - Social Login 2.7.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f3b727ba-b39c-4a98-a6a6-ea33785079f6?source=cve
Get alerted when CVE-2024-7503 or the next vulnerability affects your stack