What’s Vulnerable › Vulnerabilities
CVE-2024-7514: WordPress Comments Import & Export <= 2.3.7 - Authenticated (Author+) Arbitrary File Read via Directory Traversal
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-22
Description
The WordPress Comments Import & Export plugin for WordPress is vulnerable to to arbitrary file read due to insufficient file path validation during the comments import process, in versions up to, and including, 2.3.7. This makes it possible for authenticated attackers, with Author-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information. The issue was partially fixed in version 2.3.8 and fully fixed in 2.3.9
Affected products
- webtoffee Comments Import & Export: through 2.3.7
References
- https://plugins.trac.wordpress.org/browser/comments-import-export-woocommerce/tags/2.3.7/includes/importer/class-hf_cmt_impexpcsv-import.php#L346
- https://www.wordfence.com/threat-intel/vulnerabilities/id/30a79974-ee61-4764-8864-89659b1848a4?source=cve
Get alerted when CVE-2024-7514 or the next vulnerability affects your stack