What’s Vulnerable › Vulnerabilities
CVE-2024-7516: Brocade Fabric OS before 9.2.2 does not enforce strict host key checking
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-322
Description
A vulnerability in Brocade Fabric OS versions before 9.2.2 could allow man-in-the-middle attackers to conduct remote Service Session Hijacking that may arise from the attacker's ability to forge an SSH key while the Brocade Fabric OS Switch is performing various remote operations initiated by a switch admin.
Affected products
- Brocade Fabric OS: before 9.2.2 — fixed in 9.2.2
How to fix
Upgrade to a fixed version: Brocade Fabric OS 9.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7516 or the next vulnerability affects your stack